Creating a video

Create videos when showing the user would be more helpful than telling the user, and when a visual presentation would enhance the written description.

Software and hardware

Before you begin, make sure that you have the following software and hardware:

  • Camtasia Studio — This is your software tool for recording, editing, and producing video and audio. Download the software from the TechSmith website.
  • Chrome browser — Use Chrome to provide a consistent appearance across all product documentation videos.

  • Window Resizer Chrome add-on — This optional browser add-on helps you size your browser for optimal video recording (1920 x 1080).
  • USB headset with microphone — For audio recording and editing.

Additionally, make sure you have imported the play-video stamp to SnagIt, to be used in thumbnail images for videos embedded in easyDITA topics:

  1. Download the play-video_stamp.png file from the Product Documentation team Drive.
  2. In Snagit, click the Stamp tool.
  3. Click Import Stamps, and then import the play-video_stamp.png file.

Process overview

To create a video follow the general steps below. See other sections in this topic for detailed procedures and guidelines.

  1. Create a script.

    Note what you want to show, and what you want to say while showing it. Keep text brief and focused on what you are showing. For more information, see Creating a script.

  2. Prepare visuals.

    Create any slides you need, including title and end slides. If you will be demonstrating something in Medallia, prepare your instance. For more information, see Bumper slides and other visuals.

    Important: Do not include personal or other sensitive information in videos. For example, company names, email addresses, full names, addresses, inappropriate language, and so on. Note sensitive information you will record so you can mask it during the editing step.
  3. Rehearse.

    Practice the audio and video you want to record.

  4. Start a new Camtasia project.

    For more information, see Working with Camtasia projects.

  5. Record the video.

    Optionally, keep audio recording off to separate audio and video tracks naturally. If you keep audio recording on, you will need to separate that single video-audio track into separate tracks for editing. If you keep audio recording off, consider voicing your audio script into dead air to help you pace the actions you take in the visual portion.

    For more information, see Recording video.

  6. Record the audio.

    If you opted to record video and audio separately, record your audio now. For more information, see Recording audio.

  7. Edit the tracks.

    This includes inserting slides and other visual files, trimming unnecessary pieces of video and audio, matching audio to video, masking sensitive data, and adding transitions.

    For more information, see Editing a video.

  8. Publish the video in Camtasia.

    For more information, see Publishing a video in Camtasia.

  9. Add the video to product documentation.

    For more information, see Working with videos.

Creating a script

Always use a script. This provides an opportunity for you to refine the scope of what you want to present, edit for clarity, and make recording and editing easier.

Consider formatting your script as a simple 2-column table, matching what you want to show and do with what you want to say. Include notes that help you prepare your Medallia Experience Cloud instance, slides, transitions and other visuals. As an example, see the Report Builder Navigation script.

Working with Camtasia projects

Each video you want to produce requires a separate Camtasia project. The project contains the video and audio tracks you record, beginning and ending slides, and any other files you want to include. A Camtasia project also stores the edits you make to tracks, such as transitions, data-masking, sound dampening, and so on.

Store projects and related files in a local directory on your computer. For example, the following image shows the folder used for the Report Builder Navigation video project. The Camtasia project file has an extension of .cmproj.

A Camtasia project folder showing the project files

When you are done working with a project, upload the folder containing the project and its files to Google Drive.

For more information about working with Camtasia, see the tutorials on the TechSmith website.

Bumper slides and other visuals

Every video must have title and ending bumpers. Consider using Google Slides to create these, and save them as .png images.

  • Title slide — Use a plain white background. Text must be black, Proxima Nova, 72-point font. You can add an image, and or bullet points about what you will cover in the video. Consider making a local copy of this template to begin.
  • Ending slide — The ending slide must have a plain white background, with the company name and logo. Make a local copy of this image.

You might also create additional images and animations for your video. They must be of a file type supported for the Camtasia timeline, as noted in this TechSmith article.

Add all images to your local Camtasia project folder, and import them to the Media Bin.

Recording video

Use a large monitor (not a laptop screen) for video recordings. Videos require a resolution of at least 1920 x 1080 pixels. The Product Documentation team uses this resolution to ensure that we maintain a 16:9, high-definition aspect ratio.

Note: You can record video and audio separately or together. If you record video and audio together, you must separate the recording into 2 tracks for editing. Whenever you record audio, use a small, quiet room with no echo.
  1. In Chrome, size the viewport to 1920x1080 pixels.

    This excludes the browser's tabs, URL field, navigation buttons, bookmark bar, and so on. Record only what is being displayed in the browser, and not the browser itself. Consider using the Chrome Window Resizer add-on to make this easier.

  2. Open what you want to display in your browser.
  3. In Camtasia, select File > New Project to create a project.

    Note the location Camtasia stores your project file. Consider moving that file to a folder you have created specifically for this video.

  4. Select Edit > Project Settings, and set dimensions to 1080p HD (1920 x 1080).

    Setting project details.

  5. Click Record.
  6. If you are recording audio separately, turn off audio options.
  7. Move the video frame over the viewport of your browser.
  8. Click Start Recording.
  9. Complete the steps in your script. Note following tips:
    • If you are also recording audio, speak slowly and clearly.
    • Move at a deliberate pace. Consider leaving brief spaces of silence between steps to help the user process what you just showed, and then proceed to the next step in your script.
    • Only move the mouse as required by your script. Unnecessary mouse movements distract the user.
    • Leave brief dead space at the beginning and ending of your recording to make editing easier.
  10. When you are done, press command+shift+2 on your keyboard to pause recording, and then choose whether to Complete the recording or Start Over.

    You might have to try a few recordings before you are happy with one you want to complete.

  11. If you recorded video and audio at the same time, separate them into different tracks by right clicking the recording track in the timeline, and then selecting Separate video and audio.
  12. Select File > Save to save your project.

Recording audio

Choosing to record audio separately from video can help you focus on the needs of each track, rather than trying to get the words right as you manipulate a UI screen.

Use a small, quiet room to reduce ambient noise and echo. Speak in a clear, natural voice.

  1. Open your Camtasia project.
  2. Click Record.
  3. Turn the screen capture off, and the audio option on.
  4. Click Start Recording.
  5. Read through your script, pausing between steps.
  6. When you are done, press command+shift+2 on your keyboard to pause recording, and then choose whether to Complete the recording or Start Over.

    You might have to try a few recordings before you are happy with one you want to complete.

  7. Drag your audio recording from Finder to a new track in the Camtasia project timeline.

    Do not worry if the length of the audio track is different than the length of the video track. You will sync these tracks during editing.

  8. Select File > Save to save your project.

Editing a video

The editing process is the longest part of video production. During this phase of the process you sync video with audio, trim unnecessary pieces of video, remove ambient noises, add images, add effects, and otherwise polish the video for publication. This section provides guidelines and useful tips to use when editing a video.

Warning: Note the importance of locking tracks in the timeline.

Camtasia cares not for our petty intentions. When we instruct it to cut, move, or otherwise manipulate something in the timeline, Camtasia attempts to apply our direction coldly and mercilessly to every unlocked track at the playhead. Woe betide the video author that has sliced and diced a video track for an hour, only to discover upon playback that the audio track has suffered the same fate. Lock your tracks and rejoice!

Lock icon is gray when track is locked.

Beginning and ending images

Begin each video with its title image, placed on the same track as the video to make the transition easier. Leave the title open for 5 seconds. After 4 seconds, start a 1-second fade transition to the video track. Consider aligning audio to introduce the video while the title image is visible.

End each video with its ending image, placed on the same track as the video. As with the title image, leave the ending image visible for 5 second total, with a fade transition during the first second. Consider aligning audio with the ending image, summarizing what the video taught.

Effects

We use only the following Camtasia effects. To make editing easier, put annotations on a dedicated track in the timeline.

  • Annotations — Use circles, rectangles, and arrows to call attention to areas of a UI. Use Blur to mask sensitive data, such as company names, email addresses, telephone numbers, and so on.
  • Transitions — Use Fade to transition between most images in the video track, such as at the end of the begging slide, the beginning of the ending slide, and when an animation or other slide needs to be shown between activities in the product UI. Use Slide Right to indicate a significant passing of time, or to indicate some steps have been skipped.
  • Animations — Use Scale Up and Scale Down to zoom in and out.
  • Visual Effects — Use Clip Speed to modify the playback of a video segment. For example, your video recording might not have lingered on a part of the UI long enough to match your audio recording. In this case, use Clip Speed to slow that segment of the video recording. Very sparingly, use Mask or Spotlight when a shape or Scale Up are insufficient.

Shapes, arrows, and callouts

For shapes, arrows, and callouts use an orange color with an RGB value of 255:128:0.

SnagIT color picker

For shapes, use a width of 4. For arrows, use a width of 12 and straight flanges.

Music

Do not use music.

Splitting a track into segments

Split long tracks into segments to make it easier to align segments of audio with segments of video, and to apply effects only where needed. Consider splitting your audio track into many segments, with one segment for every step in your script.

You can also use splits to create segments that include content you want to delete, such as if you lingered too long in a part of the UI when creating the video track. In that case, create a segment of track, delete it from the timeline, and then move other segments as needed for the flow of the video.

  1. Make sure that only the tracks you want split are unlocked.
  2. Move the playhead to the place in the timeline where you want to create a split.
  3. Click the track you want split.
  4. Right-click the track and select Split at Playhead.
  5. Drag segments to new places in the timeline as needed.

Deleting a portion of a segment

You might want to delete a portion of a segment, such as if you sneezed during the audio recording, or clicked the wrong UI button during the video recording.

  1. Make sure that only the track you want to edit is unlocked.
  2. Click that track.
  3. Put the playhead where you want to begin the piece to delete.
  4. Drag the right handle of the playhead to create a range of that segment to delete.

    Video editor with playhead selectors on a track

  5. Right-click the span and select Delete Range.

    Camtasia creates an empty space between segments.

  6. Move other segments on this and other tracks as necessary for the flow of your video.

Adjusting the speed of a segment

As you synchronize video and audio segments you might find that a segment is too long or too short for its companion segment. Usually, a bit of silence as you show something is fine. However, you might find that you have recorded too little video to match the corresponding audio segment, for example. In that case, consider slowing the speed of the video segment.

  1. Use splits to create a separate segment the piece of track you want to shorten or lengthen.
  2. If you are lengthening a segment, drag other segments on the timeline to make room for the soon-to-be-expanded segment.
  3. Right click the segment you want to shorten or lengthen, and select Add Clip Speed.
  4. Drag an edge of the clip speed bar at the bottom of the segment to shorten or lengthen that segment.

    shortening the segment plays the segment faster. Lengthening the segment plays that segment slower.

    Clip speed applied to a segment at 0.61 time normal speed

  5. Preview the new speed of that segment in the canvas to ensure it appears as you want.
  6. When you are satisfied with the speed-adjusted segment, move surrounding segments on the timeline as needed to remove gaps and ensure that other tracks are aligned appropriately.

Publishing a video in Camtasia

Publishing a video turns a multiple-file Camtasia project into a single video file.

Note: Always preview your entire video in the Camtasia canvas to find and correct any errors before publishing the project.
  1. With your project open in Camtasia, select Share > Local File.
  2. In the Export As field, enter a name for the video, usually the same name as your Camtasia project file.
  3. In the File format field, select Export to MP4 (.mp4).

    Export video

  4. Click Options.
  5. In the Dimensions field, select 1920 x 1080 HD.
  6. Leave other options set to their default values, as shown in the following image, and then click OK:

    Leave default values

  7. Click Export.
  8. When Camtasia has finished the export, click Reveal in Finder.

    Click Reveal in finder

  9. Play the video file to ensure it exported without error.

Adding videos to product documentation

After you have created the video and its thumbnail image, add the video to relevant topics in product documentation as described in Working with videos.

Be sure to add the video to the Videos branch of topics, located in the Library > Content > Help > Videos branch in easyDITA.